Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2008
    Location
    Hungary
    Posts
    87
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Rides
    1

    Default Clutch Problem ?

    Hello,


    My clutch had issues back in 2017 (slip in high rev) so I bought a new Valeo kit and replaced it. Its worked like it should up until last week when after a Y-turn my cluth pedal was started to vibrate as soon as I pushed over the initial backlash. The vibration is the same as the engines. Does this mean I have to buy another kit after less than 3 years and ~15000kms or is there a cheaper/easier way to fix this ?
    1995 Alfa Romeo 155 Q4 , 1995 cc Standard Standard Black

  2. #2
    Join Date
    Mar 2014
    Location
    Bulgaria
    Posts
    120
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Rides
    1

    Default

    First "issue" look as normal wear and maybe also the engine was tuned. Does the disc look worn out then if you know.
    That vibration is an issue and its cause have to be investigated after disassembly. Here is one good article on that subject, which I found which is in Bulgarian, but you can use google translate -> https://motofocus.bg/novini/3496/vib...eizpravnostite
    One performance car is not enough ...
    Alfa Romeo GTV 2.0 V6 TB Q2

  3. #3
    Join Date
    Feb 2008
    Location
    Hungary
    Posts
    87
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Rides
    1

    Default

    I've talked with two mechanics, one of them drove my car and both said its clutch issue. The car was fine until last week when the pedal was stayed on the floor after shifting when I wanted to drove out from a parking lot.
    This pretty much means the clutch-set have to be replaced (or at least investigated after disassembly) and I doubt I will buy Valeo again and will probably opt for Sachs instead.
    1995 Alfa Romeo 155 Q4 , 1995 cc Standard Standard Black

Similar Threads

  1. GTA clutch on Q4 ?
    By kunev in forum Alfa Romeo Q4 Tech.
    Replies: 4
    Last Post: 11-08-17, 10:39
  2. Clutch Issues (again..)
    By jimnielsen in forum Alfa Romeo Q4 Tech.
    Replies: 22
    Last Post: 11-11-10, 10:54
  3. Clutch
    By Stuntz in forum Alfa Romeo Q4 Tech.
    Replies: 6
    Last Post: 06-09-09, 17:59
  4. Clutch Problem
    By jimnielsen in forum Alfa Romeo Q4 Tech.
    Replies: 57
    Last Post: 11-12-07, 00:15
  5. Anyone looking for a clutch?
    By Steve Webb in forum Alfa Romeo Q4 Tech.
    Replies: 20
    Last Post: 13-11-06, 21:15

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •