Results 1 to 14 of 14
  1. #1
    Join Date
    Aug 2014
    Location
    Sweden
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default Eprom numbers vs. ECU numbers

    Hallo all! I'm all new here!

    Right now I'm helping out a friend who is restoring a 155 Q4. He is good at cars but an analphabetic when it comes to modern car electronics. I can spell my way through eproms and ECUs, so I'm trying to help him out.

    Now, the ECU of his Q4 is marked as follows:
    IAW 4W6
    259 92
    6160010104 7770746 Z12V=
    155 2.0 TC 16V P8/P94_GA

    The original BIN-files found at this site are marked 101.03, 101.04, 101.05

    I assume that this ecu marked 6160010104 should have the 101.04 BIN file? Would that be correct? (I don't have info on model year of the car etc. at the moment).

    The chip currently in the ECU has no marking at all, and it's an UV erasable eprom so I assume it some kind of modified chip (it doesn't even have a protective sticker over the window). I thought it could be a good idea to try to start start the car with an original SW and take it from there.

    EDIT:
    My friend is in another part of the country, so I haven't looked at the ECU personally. Looking closer at the picture I now see that the eprom is soldered to some adapter board, so maybe it's a tuning chip with a copy protection board? Still I think it would be good to start off with the original BIN.


    /RedTop
    Attached Images Attached Images
    Last edited by RedTop; 15-08-14 at 08:59.

  2. #2
    Join Date
    Jan 2007
    Location
    Derbyshire, UK
    Posts
    3,055
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Welcome to the site

    Has your friend driven the car, does it run ok with the current chip? As there isn't a name it could be a cheap ebay chip, mine is a Squadra and I'm sure they're marked...the other possibility is an Evocars chip but I would think they're marked too.

    wrinx
    My Q4 in the Garage

    www.alfaromeo155.co.uk ............................ □□□-V-□□□ .................................. www.ilmostro.co.uk

  3. #3
    Join Date
    Aug 2014
    Location
    Sweden
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Quote Originally Posted by wrinx View Post
    Welcome to the site

    Has your friend driven the car, does it run ok with the current chip? As there isn't a name it could be a cheap ebay chip, mine is a Squadra and I'm sure they're marked...the other possibility is an Evocars chip but I would think they're marked too.

    wrinx
    No, he bought it partly disassembled and he's currently restoring it to running condition. I'll see if he can send me the chip and I'll read it (if possible) and see if it could be identified.

    Original question still unanswered: Is the 101.04 BIN correct for this ECU?

  4. #4
    Join Date
    Oct 2011
    Location
    Poland
    Posts
    223
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Quote Originally Posted by RedTop View Post
    No, he bought it partly disassembled and he's currently restoring it to running condition. I'll see if he can send me the chip and I'll read it (if possible) and see if it could be identified.

    Original question still unanswered: Is the 101.04 BIN correct for this ECU?
    yes should be correct
    .05 bins are for ecu's with immo
    so i assume your friend's car does not have immobiliser.

    W
    "Never take life seriously. Nobody gets out alive anyway."

  5. #5
    Join Date
    Aug 2014
    Location
    Sweden
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Thank you! I'll burn an original then, and see what I can make out of the chip currently in the ECU.

  6. #6
    Join Date
    Dec 2013
    Location
    Kalmar, Sweden
    Posts
    70
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Im the analphabetic...

    Thanks again for all help RT!
    Crister Borg
    Kalmar, Sweden
    Alfa Romeo 155 q4 -93

  7. #7
    Join Date
    Jun 2006
    Location
    Helsingborg/Sweden
    Posts
    185
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Hi,

    101.03 are for cars with intercooler water spray and Recaro seats - if I remember correctly.

    I.e. Rated 190 hp.

    Just give me a call if you want to discuss various maps more. Maybe I can source the map you have if you read it.

    Mvh
    Andreas Möller
    070-7125346

  8. #8
    Join Date
    Aug 2014
    Location
    Sweden
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Quote Originally Posted by #84 View Post
    Hi,

    101.03 are for cars with intercooler water spray and Recaro seats - if I remember correctly.

    I.e. Rated 190 hp.

    Just give me a call if you want to discuss various maps more. Maybe I can source the map you have if you read it.

    Mvh
    Andreas Möller
    070-7125346
    Thank you!

    I haven't had any success with reading the copy protected chip yet. I have a set up with an Arduino board where I can control both "chip enable" and "output enable". Difference between an ECU and an EPROM-programmer is said to be that the ECU toggles these pins between the readings, but the EPROM-programmer doesn't. So far no luck with that approach.

    Another approach is to use an ECU for reading. I've done that with a chip for a 155 2.0TS (M2.10.3 ECU). This ECU software has built in functions for reading the eprom over the OBD port, but I don't think the P8 software has that function?

    Another idea is to put the chip in a completely different ECU that can be put in bootstrap mode and read the eprom that way. Som ECUs have that feature. In bootstrap mode the ECU will never load the code in the eprom, so it should be possible to put any eprom in.
    There's an excellent forum for Boshc ME7 ECUs (mostly VAG) at: http://nefariousmotorsports.com
    where you can find more about this.

    In input on how to solve this is welcome! The purpose of beating the copy protection is only to try to find out what chip this is. I have no interest in making copies or other commercial interest.
    Attached Images Attached Images
    Last edited by RedTop; 11-09-14 at 06:44.

  9. #9
    Join Date
    Aug 2014
    Location
    Sweden
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Just an update on the story:
    By using another Eprom-programmer (MiniPro TL866) i was able to get enough information from the chip that I could see that the tuner had left his company name in an unused space of the memory. The owner (elCrillo) then contacted him and could get some interesting info on what was done etc.

  10. #10
    Join Date
    Aug 2007
    Location
    Slovenia
    Posts
    131
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Great to hear that. Was chip modified much from std? Whatkind of mod was done to maps?

  11. #11
    Join Date
    Aug 2014
    Location
    Sweden
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Quote Originally Posted by colibry View Post
    Great to hear that. Was chip modified much from std? Whatkind of mod was done to maps?

    They say they did ignition map, fuel map, boost pressure and rev limit. I know to little about these cars to tell how much it was modified, but it was an optimisation for the setup on this car.

  12. #12
    Join Date
    Dec 2013
    Location
    Kalmar, Sweden
    Posts
    70
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Crister Borg
    Kalmar, Sweden
    Alfa Romeo 155 q4 -93

  13. #13
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Great to hear that this old red beast is one step closer to spitting fire

  14. #14
    Join Date
    Jan 2015
    Location
    Melton Mowbray
    Posts
    7
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    The EPROM (code) ID is the "P94_GA"

    Can anyone confirm what the matching codes are for the 103 and 105 variants?

Similar Threads

  1. Q4 EPROM Addresses
    By Wolf66 in forum ECU and Electrical
    Replies: 62
    Last Post: 21-06-16, 23:10
  2. Delta integrale 8V ECU wierd problems
    By belidirkac in forum Lancia Tech.
    Replies: 42
    Last Post: 30-05-15, 23:38
  3. Eprom switch project
    By Gery83 in forum ECU and Electrical
    Replies: 13
    Last Post: 18-09-13, 16:29
  4. Lancia Delta Integrale 8V ECU
    By tvjensen in forum Lancia Tech.
    Replies: 3
    Last Post: 03-08-12, 17:01
  5. 155 Q4 ecu mod
    By nick in forum The Media Suite
    Replies: 6
    Last Post: 20-11-11, 18:16

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •