Page 1 of 2 12 LastLast
Results 1 to 25 of 32
  1. #1
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default alfa Romeo 155 Q4 :: 1993 Alfa Romeo 155 Q4

    1993 Alfa Romeo 155 Q4 (2012-11-21 19:57:30)

  2. #2
    Join Date
    Jul 2009
    Location
    Andalucia - Spain
    Posts
    105
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Good wheels!

  3. #3
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Engine from the other Q4 I have will be put in this one during winter 2013/2014
    It is built by a well known enginebuilder here in Sweden and my spec was max 7500rpm and 550bhp.

  4. #4
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Steeringrack swithed with one from 155 -96.
    I got this front 30mm ARB but it has not as significant bend in the center as the stock, is it for the FWD or does the frame need some modifications?

  5. #5
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    http://www.alfapower.nu/gallery.php?g2_itemId=155461This is how it looks like in differens

  6. #6
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Last edited by Norling; 26-07-14 at 08:07.

  7. #7
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    First startup with the "new" engine managed by VEMS. wasnt able to drive it that much because after installing the short shift kit is first gear always in position, I assume we need to adjust the wires. The leaks are fixed and only gearbox error and oilleak at front left driveshaft.


    https://www.youtube.com/watch?v=5ptfyfXDNC0

  8. #8
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    This engine comes from the other 155 Q4 with frame chassi we are building. We have put the engine in this car and sold the drivetrain from Golf syncro. The plan is to install engine and drivetrain from v6 Q4 from a Brera or 159Q4.

    Engine setup:
    forged pistons and conrods, adjustable wheel for cambelt, 25mm cambelt, removed balance shafts, turbo Garret GT35BB with external WG, custom inlet manifold, stainless steel manifold, 1000cc injectors, VEMS management system.
    We assume we will get around 550hp in the engine.

  9. #9
    Join Date
    Jan 2007
    Location
    Finland
    Posts
    37
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Sounds like a great plan. Will this be street legal?
    155Q4 +200hp, 156v6sportswagon +200hp, GT-06, Giulietta, 156 Crosswagon Q4

  10. #10
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    We hope but I doumbt it. There is still the issue with small brakes to solve.

  11. #11
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    First run after fixing the error with the gearbox

    https://www.youtube.com/watch?v=EtVylPuMzIY

  12. #12
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Any suggestions on harder springs for the FK coilover, its to soft with the original ones?!

  13. #13
    thesameday Guest

    Default

    So real beauties in here...

  14. #14
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    ?

  15. #15
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

  16. #16
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Any experience of the D2 coilover for trackdays?
    Witch springrate is prefered, I will use it only for trackdays?!

    http://www.d2racing.co.uk/new/products.php?prod=7

  17. #17
    Join Date
    Jan 2007
    Location
    Finland
    Posts
    37
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    They are pretty good, because we do not have a lot of options? I have a street version, should have been little stiffer springs for the trackday.
    155Q4 +200hp, 156v6sportswagon +200hp, GT-06, Giulietta, 156 Crosswagon Q4

  18. #18
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Thanks. Then I go for D2 with 180nm in front and 120nm in back. just ARB and bigger brakes left

  19. #19
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    So during the summer and autumn has their been none or almost none activity in the garage. We made a run in the dyno but oil was comming throu the turbo when getting boost. We have found the problem and solved it but lack of inspiration made in a long journey. The Garret GT35bb who is both wather- and oil-cooled in extremely sensitive if the oil is not evacuated from the turbo oilreturn, if there is any backpressure at all does it leak out and futher comes in the intake air. We have mounted a pump after the oil outlet on the turbo and pump it futher into the Engine again. We tried to connect the oil i the oilpan but it become worse. Now it runs again and we have changed to E85= 85% ethanol and 15% gas. Next thing is to find what is needed to fit pushing in stead of pulling clutch beacuse we have bought a Tilton 2 disc clutch. Does anyone have any good suggestions, Scara73?

  20. #20
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default















    Last edited by Norling; 20-12-15 at 19:38.

  21. #21
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    The tight 90 degrees bend of the elbow for the oil return from the turbo that was the problem



    The small 2dl container in witch the oil Drains into from the turbo.



    the Electric oil/diesel pump witch pumps the oil back into the Engine


    The front with new radiator witch was also damage after me putting the weld into it


    The Engine from above


    We have now beendriving the car for 140km and are ready for dyno again


    parts for pulling clutch needed for the Tilton 2 disc, thats what is lets so i need advices.

    Also the oilpump upgrade at scara73, does anyone have any experience, good or bad?

  22. #22
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    Pipes





  23. #23
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    second run spring this year
    https://www.youtube.com/watch?v=EtVylPuMzIY

  24. #24
    Join Date
    Jun 2006
    Location
    London
    Posts
    2,659
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Rides
    1

    Default

    Wow, look at that floor and boot - no rust.

    Great work going on there!

  25. #25
    Join Date
    Nov 2012
    Location
    Sweden
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Rides
    0

    Default

    True, only some small rust under the side morrors on both doors, im as confused as you, its an alfa, their must be rust
    I havent used it for 12 years, I Think thats the reason never the less there is still rust behind the mirrors...damn alfa

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •